[résolu]Ma base de données est dans les choux.

Pour parler de tout ce qui concerne l'hébergement web, c'est ici.
Répondre
Avatar du membre
Katryne
Messages : 49
Enregistré le : 12 oct. 2010 12:26
Compte LegTux : Katryne
Localisation : Provence
Contact :

[résolu]Ma base de données est dans les choux.

Message par Katryne » 13 août 2019 07:32

Hier sur https://gabandjo.legtux.org/piwigo/, j'ai installé un album Piwigo.
J'y y ai mis des photos, je l'ai fait tourner, c'était OK.
Ce matin, j'ai voulu faire des modifications de css et tout d'un coup plouf erreur mysql.
Comme je ne sais pas corriger ça, je détruis mon piwigo, je le réinstalle et ça me dit que la base existe déjà.
Quand je vais voir avec phpmy admin, c'est inaccessible.
"Impossible de se connecter au serveur MySQL"
et en dessous :
mysqli_real_connect(): (HY000/1045): Access denied for user 'gabandjo'@'localhost' (using password: YES)
Je fais comment ?

Note : je suis nulle en ce qui concerne MySQL. Quand ça va, OK, quand ça dérape, je suis perdue.
Modifié en dernier par Katryne le 15 août 2019 14:46, modifié 1 fois.

Avatar du membre
Katryne
Messages : 49
Enregistré le : 12 oct. 2010 12:26
Compte LegTux : Katryne
Localisation : Provence
Contact :

Re: Ma base de données est dans les choux.

Message par Katryne » 13 août 2019 13:12

Hello !
J'ai ajouté par ftp au Piwigo tout neuf (N°2) un thème qui semblait réclamé par le message d'erreur. Et ça commence à ressembler de nouveau à quelque chose. Ce qui semble vouloir dire que la config (spécifiant le thème) était stockée dans la base de données. Quand j'ai supprimé le Piwigo défaillant par ftp, la base MySQL est restée telle que la veille, ce qui explique mon message d'erreur quand j'ai voulu réinstaller.
Quand j'ai un accident de ce genre et que je dois supprimer les fichier du CMS par ftp, comment faire une remise à zéro de la base si je n'y ai pas accès ? C'est là où l'on voit que MySQL et moi on n'est pas copains.
Je n'ai pas posé encore la question sur le forum de Piwigo, parce qu'il me semblait que c'était un problème d'hébergement. Je veux dire pour l'utilisation de phpmyadmin.
Merci d'avance de vos conseils.

Avatar du membre
Katryne
Messages : 49
Enregistré le : 12 oct. 2010 12:26
Compte LegTux : Katryne
Localisation : Provence
Contact :

Re: Ma base de données est dans les choux.

Message par Katryne » 15 août 2019 14:45

Tout est en ordre maintenant, j'ai de nouveau accès à phpmyadmin.

Répondre