Message d'erreur lors de l'installation de Wordpress

Pour parler de tout ce qui concerne l'hébergement web, c'est ici.
Répondre
Avatar du membre
hellgorn
Messages : 9
Enregistré le : 25 déc. 2011 20:15

Message d'erreur lors de l'installation de Wordpress

Message par hellgorn » 02 sept. 2012 11:43

Bonjour,

J'ai voulu faire une nouvelle installation de Wordpress ( nouveau site :) ), mais lors de l'installation, j'ai ce message d'erreur :

Code : Tout sélectionner

Warning: file_exists(): open_basedir restriction in effect. File(/var/www/legtux.org/users/wp-config.php) is not within the allowed path(s): (/var/www/legtux.org/users/fabienhugy:/tmp) in /var/www/legtux.org/users/fabienhugy/wp-load.php on line 31


Bon, l'installation ce fait quand même sans soucis, il n'y a pas l'air d'y avoir de fonctionnalité désactivées, mais je me demandais quand même pourquoi ce message ? J'ai pu voir sur le forum que lors d'un piratage de Legtux, certaines fonctions ont été désactivés.. Et que par exemple, lors d'une mise a jour de Wordpress, on ne peux la faire directement depuis le panel ( échec des mises a jour à chaque fois, d'ou le pourquoi je réinstalle tout :) j'en profite pour refaire tout ;) ) ..

Comment palier ce problème ?

Merci

hamza
Messages : 44
Enregistré le : 09 déc. 2011 21:57

Re: Message d'erreur lors de l'installation de Wordpress

Message par hamza » 02 sept. 2012 12:26

Surement un soucis dans le relative path dans le fichier wp-load.php qui charges un fichier dans un répertoire qui est soumis à des restrictions (open_basedir). Vous devez hard-coder le path du fichier wp-config.php vous même dans le fichier wp-load.php à la line 31 avec le fonction PHP file_exists.

Avatar du membre
hellgorn
Messages : 9
Enregistré le : 25 déc. 2011 20:15

Re: Message d'erreur lors de l'installation de Wordpress

Message par hellgorn » 02 sept. 2012 12:51

Merci de ta réponse si rapide ;)
En effet c’était bien cela.. Wordpress utilise une condition pour vérifier les fichiers de configuration..

Code : Tout sélectionner

elseif ( file_exists( dirname(ABSPATH) . '/wp-config.php' ) && ! file_exists( dirname(ABSPATH) . '/wp-settings.php' ) ) {

   /** The config file resides one level above ABSPATH but is not part of another install */
   require_once( dirname(ABSPATH) . '/wp-config.php' );

}


et dirname(ABSPATH) renvois vers un dossier qu'on est pas censé avoir accès :)
Mais du coup vu que c'est une condition qu'on n'a normalement pas besoin, aucun soucis ;) rien besoin de modifier :)

Merci pour ta réponse ;)

Avatar du membre
Simon Le Guével
Administrateur
Messages : 1284
Enregistré le : 04 sept. 2010 12:30
Compte LegTux : simon
Localisation : Saint-Brieuc
Contact :

Re: Message d'erreur lors de l'installation de Wordpress

Message par Simon Le Guével » 02 sept. 2012 13:53

C'est bien ça :)

J'en ai profité pour t'activer la fonction qui est nécessaire pour les mises à jour Wordpress.

Avatar du membre
hellgorn
Messages : 9
Enregistré le : 25 déc. 2011 20:15

Re: Message d'erreur lors de l'installation de Wordpress

Message par hellgorn » 07 sept. 2012 08:15

Haa Nickel, parfait, Merci ;)

Répondre