[Résolu]Un problème de DNS ?

Un soucis avec les serveurs DNS ?
Répondre
sempervivum
Messages : 7
Enregistré le : 07 sept. 2010 11:27

[Résolu]Un problème de DNS ?

Message par sempervivum » 03 févr. 2013 07:44

Bonjour

J'ai un domaine DNS chez OVH que j'ai redirigé vers Legtux depuis hier.

Code : Tout sélectionner

$TTL 86400
@   IN SOA dns10.ovh.net. tech.ovh.net. (2013020115 86400 3600 3600000 86400)
                    IN NS     ns10.ovh.net.
                    IN NS     dns10.ovh.net.
                    IN MX 1   redirect.ovh.net.
*                   IN A      91.121.155.10
@                   IN MX 50  mail.legtux.org.
@                   IN A      91.121.155.10


Legtux a accepté mon domaine et mon site est visible: http://www.chromaphyosemion.be

Mais quand je clique dans mon menu, l'adresse redevient une adresse legtux, par exemple:

http://www.chromaphyo.legtux.org/les-especes

alors que je voudrais soit garder l'adresse http://www.chromaphyosemion.be ou l'adresse http://www.chromaphyosemion/les-especes

Est-ce possible à faire et est-ce un problème DNS ?

Merci beaucoup pour votre aide !
Modifié en dernier par sempervivum le 07 févr. 2013 04:46, modifié 1 fois.

Avatar du membre
Simon Le Guével
Administrateur
Messages : 1267
Enregistré le : 04 sept. 2010 12:30
Compte LegTux : simon
Localisation : Saint-Brieuc
Contact :

Re: Un problème de DNS ?

Message par Simon Le Guével » 03 févr. 2013 19:41

Bonsoir,

Non, il s'agit simplement de la configuration de votre CMS qui génère des liens sur l'ancienne URL. ;)

sempervivum
Messages : 7
Enregistré le : 07 sept. 2010 11:27

Re: Un problème de DNS ?

Message par sempervivum » 05 févr. 2013 13:46

Merci pour ta réponse Simon :)

Sans doute un problème avec .htaccess alors ?

Si je mets ceci :

Code : Tout sélectionner

Options +FollowSymlinks
RewriteEngine on
rewritecond %{http_host} ^chromaphyosemion.be [nc]
rewriterule ^(.*)$ http://www.chromaphyosemion.be/$1 [r=301,nc]


je suis bien redirigé vers http://www.chromaphyosemion.be quand je fais l’adresse http://www.chromaphyo.legtux.org

Mais ensuite quand je clique dans le menu j'ai une erreur car ça me redirige vers http://www.chromaphyo.legtux.be

Je rame un peu beaucoup. Auriez vous une solution ?

Merci

Avatar du membre
Simon Le Guével
Administrateur
Messages : 1267
Enregistré le : 04 sept. 2010 12:30
Compte LegTux : simon
Localisation : Saint-Brieuc
Contact :

Re: Un problème de DNS ?

Message par Simon Le Guével » 06 févr. 2013 00:59

Il faut modifier la configuration de CMS Made Simple pour lui indiquer la nouvelle adresse, il générera alors les liens du menu avec le bon domaine ;)

sempervivum
Messages : 7
Enregistré le : 07 sept. 2010 11:27

Re: Un problème de DNS ?

Message par sempervivum » 07 févr. 2013 04:46

Merci Simon, c'est résolu :)

Répondre