erreur 500 avec mon .htaccess

Forum du fonctionnement général de LegTux.
Répondre
eldo
Messages : 2
Enregistré le : 19 avr. 2012 12:02
Compte LegTux : sitewebfacile

erreur 500 avec mon .htaccess

Message par eldo » 19 avr. 2012 12:19

Salut, je voudrais que toutes mes pages sauf ceux qui sont dans les dossiers ajax et assets soient redirigées vers index.php. Pour cela j'ai mis le .htaccess suivant:

Code : Tout sélectionner

#   Empêche la visualisation de l'arborescence, n'a rien à voir avec le masquage du « index.php ».
Options -Indexes

#   Active le module de réécriture d'URL.
RewriteEngine on

#
#   Fixe les règles de réécriture d'URL. Ici, nous utilisons une liste blanche.
#
#   Toutes les URL qui ne correspondent pas à ces masques sont réécrites.
RewriteCond $1 !^(index\.php|load\.php|ajax/|assets/)

#   Toutes les autres URL vont être redirigées vers le fichier index.php.
RewriteRule ^(.*)$ index.php/$1 [L]
.
Tout fonctionne en local mais el ligne ça me met une erreur 500.

Répondre